Scientific Visualization with Easy-Viz

Results in scientific research are often in the form of data sets describing a certain phenomenon. They can be the result of sampling or numerical simulations. And even though valuable information can be obtained from these sets, the amount of data to analyze can be overwhelming. Here is where scientific visualization proves to be very useful, providing insight for patterns and behavior trends by using visual means.

Easy-Viz provides quick visualization of scalar data on a 2D domain. We can think of this as a terrain map where a scalar value (data) for altitude corresponds to each coordinate pair -latitude and longitude in this case.

The scalar value could represent any event such as heat, pressure, or density at a certain location and/or time. More formally, it is defined by 
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where the function f describes the phenomenon which is dependant on the values of x and y.

Most events in nature are continuous. However, since computers are finite machines, the data set also must be finite, i.e. there must be a finite number of columns and rows. Basically, our discrete approximation is a 2D grid.
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Figure 1  Discrete 2D grid

Scientists know that the finer the grid, the better the approximation of the continuous observable fact. Nevertheless, computational issues often place limits on the resolution of data sets.

Easy-Viz basics

Easy-Viz includes a sample data set file -input.vtk- which we can use as we walk through the visualization topics and software features. Just in case, the grid on Figure 1 does not correspond to the data set contained in input.vtk.

To start the application,

· Double-click the Shortcut to Easy-Viz on the desktop.

· Click OK on the Info box. There are a few times when Info boxes appear while using Easy-Viz. We just need to click OK to close them.

The visualization of the data set appears in the main window. In order to understand how the data is represented, we need to know the coordinate system used in the screen. The axes are named X, Y and Z. How they are positioned on the screen depends on the current view. The available canonical views can be selected in the View menu and they can be summarized in the following table:

	
	Screen plane (horizontal/vertical)
	Axis perpendicular to screen

	Front
	XZ
	Y

	Side
	YZ
	X

	Top (default)
	XY
	Z


Figure 2  Canonical views

Since the data set is a 2D grid, the basic representation object will be a plane coplanar to the XY plane by default. The window location of the coordinate origin depends on the data set. Now, let’s take a look at the included sample file.

To open the sample file, 

1. Click on File->Open
2. Select the .vtk file (input.vtk in this case)

3. Click the Open button

Once the file is open, the visual representation or data object appears on the screen as shown in Figure 3.
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Figure 3  Visualization of input.vtk

Let’s take a look at this image for a while. As mentioned before, the plane object is coplanar to the XY plane, which is also coplanar to the screen in the default view (Top). 

Remember that in this view, the positive Z-axis sticks out the screen. 

Easy-Viz performs two types of visualization:

· Color mapping (default)

· Warping or scalar generation

As its name indicates, color mapping maps each scalar value with a different color. For example, Figure 3 shows a certain phenomena in which red color indicates higher scalar values while blue indicates lower ones.

Instead of using colors, warping generates a 3D surface where the scalar data value provides the Z coordinate.

To add warping in the data object, 

1. Click on Edit->Color Map
2. Click on the Warp checkbox to enable/disable it

3. Click on the Apply button

4. Click on the Close button

A view from the Top does not let appreciate the warping features of the data object. But we can move on to the other canonical views in the View menu.
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Figure 4  Side view of input.vtk coupling color mapping and warping

As we see, these two visualization types are not mutually exclusive and interesting results are obtained when they are applied together.

Also note that the side and front view won’t be of much help if warping is not enabled. Why?

The surface mode of the data object can be set to Surface (default) or Wireframe on the View menu. The surface mode gives as an approximation of the continuous phenomenon we are representing, while the wireframe lets us visualize the degree of discretization in the data set.

[image: image4.jpg]



Figure 5  Data set represented in wireframe mode

There is a color property that serves the same purpose. When Interpolate is enabled (default) on the View menu, the object shows a smooth change in the colors approximating the continuous event. When disabled, a different color hue appears for each cell with sharp boundaries corresponding to its scalar value, and showing the degree of discretization of the data set.
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Figure 6  Data set with color interpolation disabled

Reference information about the data object can be included in the main window by adding a title, axes parameters and a color bar. To keep dialog boxes from appearing and disappearing, we must make sure that they do not overlap with the main window.

To add a title,

1. Click on View->Title
2. Set the text, font size, color, and visibility of the title.

To visualize the coordinate axes,

1. Click on View->Axes
2. Set the labels for each of the axes and their font size with a slider

3. Set the color and visibility of the axes.

To include a bar showing the color map,

1. Click on View->Color Bar
2. Type in a title for the bar 

3. Set the number of labels (ticks), the bar width using the slider, and the visibility.

We may also want to change the background color to enhance the appearance of the visualization. To do so, we should click on Options->Background Color. All colors can be obtained by combining red, green and blue hues. The dialog box provides sliders so we can control the contribution of each of the primary colors. Alternatively, we can just click on the wheel to select directly the color we want for the background.

Rotation, zooming and panning

The canonical views are not the only ways to look at a data object. We can adjust the view as we wish by using the mouse. The operations available are rotating, zooming, and panning. 

Data objects and the coordinate system can rotate around arbitrary rotation axes as long as the rotation axes are located on the screen plane. In the default configuration, all the rotation axes intersect at the center of the main window. How can we rotate a data object around an axis perpendicular to the screen?

To rotate a data object,

· Drag the mouse in the direction of rotation while holding down its left button. 

Rotation is useful when the object is of warping type because it allows detailed observation of its 3D features.

If after rotating the object for a while, its orientation gets confusing, we can always reset the position and orientation by selecting one of the canonical views in the View menu.

Zooming allows the viewer to get closer or farther from the data object.

To zoom on a data object,

· Drag the mouse vertically while holding down its right button. 

When the mouse is moved upward, the object gets closer, but when the mouse is moved downward, the object moves away from the viewer. Horizontal mouse displacements do not have any effect in zooming.

Panning allows displacement of the object in the screen plane.

To pane a data object,

· Drag the mouse while holding down its right button and the CTRL key.

The object will move along with the mouse pointer.

Color Mapping
The default color mapping ranges from blue for the lowest value to red for largest one (Blue to Red), but it can be modified according to our needs.

To modify the color mapping,

· Click on Edit->Color Map
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Figure 7  Color Map dialog box

Once the respective dialog box appears, we can choose how the colors are going to span the values of the data set.

The Number of Colors is a parameter analogous to resolution. The more colors are available in the map, the smoother the color changes appear in the object. This shouldn’t be confused with color interpolation in which the colors are blended among cells. The Range of Values can be changed so that they correspond to the scalar values in data set. The range must be set in ascending order. These parameters can be returned to their original values by clicking on the Set Default button.

A custom color map can be constructed by selecting Create own color table. In the input box, each row contains a value/color pair separated by blank(s). A simple color table may look like the table in Figure 8.

	-6.
	blue 

	-4.
	Blue_light 

	-2.
	cerulean 

	0.
	chartreuse 

	2.
	Cyan 

	4.
	eggshell 

	6.
	english_red


Figure 8  Sample custom color map

To create a table like this, first enter a number in the text box and then simply double-click on the desired color in the scroll list at the right. We can edit the contents of the text box to make any changes.

Data analysis/extraction

In addition to visualize data with colors and warped surfaces, we may want to extract numerical information visually such as finding the coordinates and data value of a certain point, or measuring the distance between two points in the data object. More interestingly, we may want to look at the behavior of the event when one of the coordinates is constant (cross sectioning). Easy-Viz provides options to perform all these operations.

To obtain visually the coordinates of a point and it’s associated scalar value,

1. Click on Tools->Position & Data
2. Click on the object point we want to obtain information from with the left button while holding down the CTRL key.

The set of coordinates and the scalar value will come out in the respective window. For planar objects, the Z coordinate remains constant at zero, but if the surface is warped, the particular Z value will be shown.

To measure the distance between two specified points,

1. Click on Tools->Measure Distance
2. Click on the first object point with the left button while holding down the CTRL key.

3. Click on the second object point with the left button while holding down the CTRL key.

A separate window will appear showing the coordinates of the two points and distance between them.

Cross sectioning is a bit more complex but still straightforward operation. We could say that it is like taking a knife, cutting the data object, and then looking at the edge of the cut. Would it be useful to perform this operation on a flat object (plane)?

To start cross sectioning, 

· Click on Edit->Cross Section
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Figure 9  Cross section dialog box

Then we need to determine which coordinate will remain constant at the cross section, i.e. x or y, specify its value, and click on the Draw button. A window will appear showing the plot. Multiple plots can be added in the same window by changing the parameters and clicking the Draw button again.
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Figure 10  Cross sections plots

We can delete the last added plot or all of them by clicking on Delete Last and Clear All button, respectively. We can also set the plot Resolution, keeping in mind that the higher the resolution, the smoother the plot curve.

There is an alternate way to input the constant coordinate value. When clicking on Show/Activate Slider Bar button, its label will change to Hide Slider Bar and a red line will appear on the data object in the main window, indicating the location of the cross section. We can slide it by clicking on it with the left mouse button while holding down the CTRL key. Note how the coordinate values change simultaneously in the dialog box when sliding the bar. To get rid of the slider bar, just click on the Hide Slider Bar.

We can provide reference information in the cross section plots by adding a title, labeling and setting the number of ticks on the axes. The number of ticks should be a power of two, e.g. 2, 4, 8 and so on. The plot legend(s) can be turned on or off by clicking in the Legend Off checkbox.

Importing / exporting data procedures

Finally, we’ll work on the procedures to import/export data from Easy-Viz to other applications and vice-versa. As an exercise, we can work with input.vtk.

To export a .vtk file to Excel (text) format,

1. Click on File->Export toExcel
2. Select the file to be exported. 

3. Create or select the destination file (input.txt in this exercise)

Input.txt can be opened in Excel, but a few steps are required to open it successfully.

To open the exported file in Excel,

1. Start Excel

2. Click on File->Open
3. Select the exported file

When the Text Import Wizard appears in Excel,

4. Select Delimited as the Original Data Type
5. Click the Next button.

6. Click on the Space checkbox 

7. Click the Finish button.

Now, we can take a look at the data contained in the file: the values for the axes and the grid data. Note that the original .vtk file remains intact.

Most of the time, we’ll use the reverse procedure –importing data results from another application. We can practice with the exported file we just created (input.txt) to create a new .vtk file from it.

To create a .vtk file,

· Click on File->New
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Figure 11  New File dialog box

To input information about the axes,

1. Type in the number of columns (X coordinates) and rows (Y coordinates)

2. Click on the Advanced button for each axis.

We can select Default values for coordinates, define a Range, list the coordinate values separated by blank(s), or copy them from another application using the Paste button.

The Data Values can be listed in the dialog box, but it is a better idea to copy them from another application since they may be quite numerous. Remember having selected and copied the values from the origin application before clicking on the Paste button. To complete the import procedure, we must click on the Save button and name the file.

In addition to import/export procedures, we may want to save the visualizations and plots into a graphics file for sharing or publishing. Again, make sure that there are not windows or dialog boxes overlapping the image we want to save.

To save as an image file,

1. Click on File->Save Image
2. Select the appropriate window

3. Click on Save As button.

4. Select the graphics format, name the file and save it.
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